Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BHI260AP Klio Firmware

    BHI260AP Klio Firmware


    Hi everyone,

    the Niclas Sense ME documentation states that the pre-programmed firmware of the BHI260AP chip does not support the self-learning AI features yet. However, a different pre-built firmware called 'Klio' is available for the self-learning AI core.

    Where can this firmware be downloaded?

    Best regards

    6 REPLIES 6

    Community Moderator
    Community Moderator



    Regarding this issue, you need to submit our contact form. 

    Please visit, and use the contact form to submit your request.

    Please let me know if you have any questions. 



    now I finally have access to the firmware but I am still unable to upload it to the BHI260AP flash.

    I followed the instructions on uploading firmware to the Nicla Sense ME using OTA via BLE in the beforementioned documentation. I can connect to the board but when I press "Upload" the connection status will change to "Disconnected" after ~ 1 min and the board wil not be visible until restarted. A progess bar appears but no progress is made.

    Reading and configuring the sensors in the web interface works just fine. Also, I tried with Microsoft Edge and Google Chrome on both Windows 10 and Ubuntu. Using the built-in tools in the Arduino IDE for updating the NRF52 chip works as well, although uploading the NRF52 firmware via BLE leads to the same result as described above.

    Could you please verify that firmware updates using OTA via BLE for the Nicla Sense ME as well as the BHI260AP work for you and hint me on what I did wrong?



    Long-established Member


    Thanks for posting your concerns.

    The guide regarding FW OTA for the BHI260AP and the Nicla has all been verified. One example video could be checked here:

    In my personal experience, it was  observed some old PCs might get disconnected in the mid of the update, it also has to do with interferences etc.

    In case, you can not update the FW OTA, another method has been added to the documentation, please look for: "Using the Sketches as a Step Stone / Agent", please let us know if this helps.


    thank you for your help and updating the documentation.

    The method "Using the Sketches as a Step Stone / Agent" worked  perfectly fine for me.