Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BME 688 I cannot find raw data on SD card

    BME 688 I cannot find raw data on SD card



    I tried BME688 with Adafruit board, but I could not see any raw data. Here is what I tried.

    • Assembled BME 688 dev-kit and Adafruit HUZZAH32 feather board.
    • Copied *.bmeconfig file into microSD card (SD card was eFAT format).
    • Inserted microSD card into Adafruit board.
    • Put CR1220 coin cell into BME 688 board.
    • Connected board to Windows PC and installed USB driver.
    • Run "flash.bat" on PC. It was successfully finished. 
    • Plug out USB cable.
    • Provided power from USB cable. Red LED flashes very quickly. (Seems no change??)

    What was wrong in my process?

    6 REPLIES 6

    Community Moderator
    Community Moderator

    Hi sotan,

    After you install hardware & software, you need to refer start guide to record data.

    BME AI-Studio.png

    BME AI-Studio video.png

    Hello BSTRobin, 

    Thank you for your reply. 

    Yes, I did the same thing in "Get started", but I could not find any raw data in SD card. 

    What I don't understand is that red LED blinks very quickly, but in the movie in "Get started", it blinks every 1 or 2 seconds. 

    My questions :

    • Why red LED blinks so quickly? What does this mean? 
    • How SD card needs to be formated? Is it ok in eFAT format?
    • Where to copy *.bmeconfig in SD card?
    • Are there anything I need to confirm?

    Thank you, 

    Community Moderator
    Community Moderator

    Hi sotan,

    The Demo program is published as a bin file.
    BME688 dev kit contains 16 GB microSD card with config files, don't need do any modification.
    Do you strictly follow the getting started guide to use it? We can't reproduce your problem.
    Connect the serial terminal detection tool. The print information of BME688 dev kit is as follows on my side.

    BME688 dev kit startup log.png


    Hello BSTRobin,

    Thank you very much for your reply. It was very useful.

    I confirmed same things as yours and found some error. (Error code = -2)

    What does this error code mean? What was wrong in my environment?