Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BME 688 Red LED is blinking continuously, and no data is being recorded

    BME 688 Red LED is blinking continuously, and no data is being recorded


    I,ve got a new BME 688 Dev kit and Adafruit feather board. I tried configuring the board.

    1 - I made the Feather board ready

    2- Put, SD card and coin cell battery to the board

    3 - Flashed it through the software 

    4- I did not find any .bmeconfig in the downloaded folder but obtained the default version in the forum and copied that to my SD card. (BME Dev kit 2.0.6 & BME AI studio 2.0.0)

    5- The LED was blinking continously and I was using a class 10 SD card and I thought that would be the issue (Found a same issue with a member here) I changed my SD card and the LED is still blinking continously with no change. I tried re-flashing it, but no help!!

    6- I created a new .bmeconfig file using the AI studio and put it in the SD card. Still no change and no data being recorded!!

    Does the LED flash like this and not record data for the initial 24-48 hours?? What would be the problem? Please help me..

    This was the files in the Dev kit software package. No .bmeconfig fileThis was the files in the Dev kit software package. No .bmeconfig fileFlashing dialogueFlashing dialogue

    9 REPLIES 9

    Yes, I did that. I even got a new board and tried everything. Same problem, the RED LED is flashing continously. It was flashing once in 2 second untill I flashed, Is there a way I can get the old development software versions for flashing? not the 2023.

    Community Moderator
    Community Moderator

    Hi atsaleel,

    We have internal suggestions to keep different versions of the software on the official website so users can compare them.

    I am also having the same problem. After using the flash file 2.0.9 my led is flash blinking and no data is being recorded.
    I have the bmeconfig file on sd card

    Pls help




    I was having this same problem.  The issue I found was a cold solder joint on the MISO line going to the SD card. Check the MISO/MOSI line from the Wroom32 to the Card reader and make sure they are good.  I reflowed the SD card socket and the problem went away.

    Community Moderator
    Community Moderator

    Hi Mitesh,

    You should input "COM4", not "com4".

    Hi lunacyworks,

    Good news.