Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BME 688 Red LED is blinking continuously, and no data is being recorded

    BME 688 Red LED is blinking continuously, and no data is being recorded


    I,ve got a new BME 688 Dev kit and Adafruit feather board. I tried configuring the board.

    1 - I made the Feather board ready

    2- Put, SD card and coin cell battery to the board

    3 - Flashed it through the software 

    4- I did not find any .bmeconfig in the downloaded folder but obtained the default version in the forum and copied that to my SD card. (BME Dev kit 2.0.6 & BME AI studio 2.0.0)

    5- The LED was blinking continously and I was using a class 10 SD card and I thought that would be the issue (Found a same issue with a member here) I changed my SD card and the LED is still blinking continously with no change. I tried re-flashing it, but no help!!

    6- I created a new .bmeconfig file using the AI studio and put it in the SD card. Still no change and no data being recorded!!

    Does the LED flash like this and not record data for the initial 24-48 hours?? What would be the problem? Please help me..

    This was the files in the Dev kit software package. No .bmeconfig fileThis was the files in the Dev kit software package. No .bmeconfig fileFlashing dialogueFlashing dialogue

    9 REPLIES 9

    Community Moderator
    Community Moderator

    Hi atsaleel,

    1.What is the blinking frequency of the red LED?
    2.You need to ensure that you have correctly flashed the v2.0.6 software to BME688 dev kit;

    BME688 dev ket setup.png
    3.I uploaded a .bmeconfig file. You can put it on the SD card and refer to the video( to see whether the data can be recorded normally?


    Thank you for the help. The RED LED is flashing very frequently, less than 1 sec. I followed the instructions in the flyer. But it is not recording the data. My doubts are, 

    1 - What format the SD card should be and does the name matters?

    2 -Is there a way I can delete the flashed software and redo in the ESP32? I tired re-flashing it again and again, it was successfull from the dialogue but still not recoding the data! 

    3- I am using a SanDisk 16 GB, Class 4 (which was shown as part of the bundle) 

    Is there any obvious that I am missing? I should not flash it before 24 hours stabilization?

    I also tried erasing the ESP32 and flashing again. But the moment I flashed, RED LED starts blinking frequqntly. Is there a way I can get the older versions? The flash files for ESP32 and AI version?

    Community Moderator
    Community Moderator

    Hi atsaleel,

    There is no documentation to indicate that there are special requirements for SD card.
    On my side, SD card is in FAT32 format.
    The software supports new burning, and the new software will overwrite the old one.
    I used SanDisk 16 GB, Class 10.

    Did you copy to previous attachment config file to your SD card and test recording data?