Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BME688 Dev kit not working

    BME688 Dev kit not working



    i am trying to use BME688 DEV kit, after combine the kit with huzzah32. I plug in the power and the red LED on the board flash 5 times and pause for 1 second. Do you know what does that mean? And the SD card has no data stored.

    1. do I have to put in the re1220 coin in the board? i have to use the exact type of SD card? now am using gigastone 4k camera pro.

    thank you,



    4 REPLIES 4

    Community Moderator
    Community Moderator

    Hi Grayson,

    1.You don't need to install batteries;
    2. BME688 dev kit has no special requirements for SD cards, just use a universal SD card.

    Did you refer BME688 dev kit setup guide and finish the setup?

    New Poster

    I had the same problem you did. My brand new June 2023 bme68x dev kit had 'something' blinking the red LED at 1 Hz but nothing was saved to the SD card. I also suspected the SD card. I tried reflashing the source code onto the Adafruit ESP32 Feather with Arduino IDE. That is a bust with the latest and greatest libraries. It 'compiles' but fails at the linking(LD) stage of the process. Not enough RAM by a few thousand bytes. 

    I sucessfully flashed bme688_dev_kit to the Feather. This verified the SD works. Data was being saved in .csv format. Better but not correct.

    Next I tried flashing the bin files contained inside ""

    This was a _not_fun_ experience. The Flash.bat file is a nasty cut and paste error!!! It starts with windoze backslashes and ends with *nix slashes in the filenames.

    The Flash.bat file may work in win if you replace the slashes in the path/file/names with windows\path\backslashes.

    I ended up running the python3 code from the command line with fixed pathnames and variables from the .bat file. I am now a happy camper and the bme688 is recording jsondata in a file on the SD card (as they said it would out of the box).

    My Linux python3 command line is below


    python3 \
    --chip esp32 \
    --port /dev/ttyUSB0 \
    --baud 921600 \
    --before default_reset \
    --after hard_reset write_flash \
    -z \
    --flash_mode dio \
    --flash_freq 80m \
    --flash_size detect \
    0xe000 esp32/2.0.3/tools/partitions/boot_app0.bin \
    0x1000  esp32/2.0.3/tools/sdk/esp32/bin/bootloader_dio_80m.bin \
    0x10000 bme68x_demo_sample.ino.bin \
    0x8000 bme68x_demo_sample.ino.partitions.bin \




    Hi all,

    1. Ensure the use of official hardware;
    2. If using the latest software, please record detailed failure records, such as viewing the printed information of the COM interface and screenshots of the SD card content.