Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BME688 connection to Android App

    BME688 connection to Android App

    Established Member


    I am trying to use the BME688 Andriod APP that was recently released. The App is able to connect to the BME 8x board via bluetooth.  The SD card with the config file is present. (i.e it is logging data). but right after the app connects, i get this msg on the APP :

    "Could not start sensor. response code: BSEC_CONFIG_MISSING"

    if i look at the SD card and open a raw data file it creates (its flashed with the bme68x_demo_sample.ino.bin ) - i see this header.. as a appVersion of 0.7.4 not sure if this works with the App that i downloaed for the Andriod. 

    "configHeader": {
    "dateCreated": "2020-10-20T08:54:10.804Z",
    "appVersion": "0.7.4",
    "boardType": "board_8",
    "boardMode": "heater_profile_exploration",
    "boardLayout": "grouped"
    } ....

    i have a *.bmeconfig in the SD card. so not sure what else is needed. again no documention etc. so its very tiny bit frustrating. 



    39 REPLIES 39

    Community Moderator
    Community Moderator

    We will plan to release new app and firmware soon, so could you upgrade firmware and app and test it again? 

    Sorry for inconviniecen. 

    Thank you. 

    Established Member

    I have now updated to:

    • AI Studio 2.0.0 for Windows (old / before  1.7.1)
    • Arduino development kit software / Feather binary 2.0.6 (old / before 1.5.5)
    • BME688 Development Kit App 1.1.3 still the same, no update on your software page

    After that I updated the Feather firmware via flash.bat in BME688_Development Kit Software_v2.0.6 to the latest version and I generated a new *.bmeconfig file and BSEC config files with AI Studio 2.0.0. The *.bmeconfig file and and BSEC config files have been saved to SD and inserted in the Feather dev board.

    I connected the board to my Android phone and got the same unusable behavior as before!


    Testing and Environment is still greyed out and I can not test my via AI Studio generated model. Is there any other way (e.g. via AI Studio) to test my model and get a classification (e.g. coffee vs. air) out or must I use the Android app for that only?

    In addition I tested a completely new project (no old trainings data, no old config files) with the "new" AI Studio and Arduino binary:

    • generate .bmeconfig file with AI Studio
    • copy .bmeconfig file to SD card
    • power the Adafruit Feather and collect data from air, coffee, air, cheese, air
    • make a new AI Studio project
    • import the raw data from SD
    • train the algorithm
    • generate BSEC config files
    • copy 2023_02_24_17_35_coffee-vs-cheese_HP-354_RDC-5-10.config and 2023_02_24_17_35_coffee-vs-cheese_HP-354_RDC-5-10.aiconfig to SD
    • run Feather and Android App

    See only a chart similar to


    But would expect something like you have shown in differen videos Especially the classification result as shown here but I never got:

    2023-02-24 18_58_59-Greenshot.png

    Or a mode to tag data, I think this is done here:

    2023-02-24 18_57_53-Greenshot.png

    We have ordered four BME688 development kits for a workshop next week and I and my colleague have spent hours to get this f...abulous software working. In case we can not manage to run the Bosch software till next week we have to communicate in the workshop that the software lacks and / or the documentation in-sufficient is.

    An other colleague asked a time ago about Bosch and Bananaware and I replied to and came to Bosche's defense that time. But after your update and a repeated unsuccessful tial and a lot wasted time I would say, yes Bananaware.

    In case we can not solve the problem timely with your help we will return the ordered BME688 development kits because they are usless for as. So please provide a working environment and a proper documentation for your products.

    Similar / same? issues in

    So it seems it's not a problem for me only, please fix this, we can not work on with your product without a solution, aka working App!


    Same incompatibility overhere...

    The exported BSEC Config File from BME-AI-Studio is not recognised by the Development Kit App v1.1.3. In BME-AI-Studio it also mentions "Compatible with Development Kit Firmware version 2.0.5 and AI-Studio Mobile App 2.0". I tried to change filenames from .config to .conf and others things, unfortunately without success.

    That means the created algorithm can not be checked/tested with the mobileApp. Maybe the created .c and .h files can be used in a production_sketch!?

    I hope Bosch developers can update the issues soon.

    Established Member

    Any comment or solution @Minhwan or @BSTRobin? Our last idea to go on was to search for the iOS BME688 app as mentioned in the official Bosch Sensortec YT channel in this video . At 0:22 you are talking about the App that "is available for iOS and Android". Our intention: Perhaps is the iOS App more reliable and compatible with the latest AI Studio desktop code / config than the publish old Android apk. We could not find a / "the" AI Studio iOS app as mentioned, so a colleague from me called the German Sensortec department in Stuttgart. The answer was, they do not know any iOS app for the BMExx / Bosch AI Studio Mobil??! What!? So please enlight us and help us getting the fingers dirty with your tiny nice AI module, and perhaps update your website with sufficient information or your colleagues in Stuttgart, Germany! 

    Community Moderator
    Community Moderator

    Hi @Clemens , 


    Currently, we are working on new apk and hopefully launch around middle of march. 

    Let you know once apk is released. 

    Sorry for inconvinience.