Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BME688 connection to Android App

    BME688 connection to Android App

    Established Member


    I am trying to use the BME688 Andriod APP that was recently released. The App is able to connect to the BME 8x board via bluetooth.  The SD card with the config file is present. (i.e it is logging data). but right after the app connects, i get this msg on the APP :

    "Could not start sensor. response code: BSEC_CONFIG_MISSING"

    if i look at the SD card and open a raw data file it creates (its flashed with the bme68x_demo_sample.ino.bin ) - i see this header.. as a appVersion of 0.7.4 not sure if this works with the App that i downloaed for the Andriod. 

    "configHeader": {
    "dateCreated": "2020-10-20T08:54:10.804Z",
    "appVersion": "0.7.4",
    "boardType": "board_8",
    "boardMode": "heater_profile_exploration",
    "boardLayout": "grouped"
    } ....

    i have a *.bmeconfig in the SD card. so not sure what else is needed. again no documention etc. so its very tiny bit frustrating. 



    39 REPLIES 39

    Like earlier users, I have not been able to get the phone app to work. My experience follows closely that described by @Clemens. I am using the BME688 shuttle board with the Adafruit HUZZAH ESP32 board purchased separately.

    I am able to collect data and train the algorithm but gas detection does not work. I am including pictures showing what the app does when configuration files are copied to it.

    This apparently a long-standing problem and should be fixed asap. Very disappointing.





    Occasional Visitor

    I'm exactly in the same situation as the previous person! And of course, I have the same issue! So please Bosch, can you do something about that? And also, this topic can not be marked as SOLVED!

    Community Moderator
    Community Moderator

    Hi all, 


    New Andorid app is updated. Could you test it with latest firmware and AI studio? 

    Thank you. 

    Established Member

    Hello minhwan.

    Here's a newbie question: How can I update the firmware of BME688 boards?

    Edit: Already solved. On page 4 of this same publication, the procedure was already explained. It can also be found in "BME688 Dev-KIt Flyer".

    Hi Minhwan,

    It seems to be working now. Thank you!