Bosch Sensortec Community

    cancel
    Showing results for 
    Search instead for 
    Did you mean: 
    SOLVED

    BMI088 giving wrong accelerometer RAW data?

    Community Moderator
    Community Moderator

    Re: BMI088 giving wrong accelerometer RAW data?

    Hi ZeeshanAziz,

    I could not open this file as I do not have Matlab on my PC. But from your description the issue is not likely to come from the sensor, but rather from your test setup.

    The accelerometer responds the the physical input. There may be some misalignment between your reference measurement and the actual sensor position
    Member

    Re: BMI088 giving wrong accelerometer RAW data?

    I am using matlab just for getting the data and plotting that data. I am doing all the calculations on STM32 Discovery board. I am also using complementary filter and the formula that I am using for calculation roll and pitch is "atan2(ACC_z, ACC_x)" and "atan2(sqrt(ACC_z*ACC_z + ACC_x*ACC_x),-ACC_y)" respectively. Now I have also attached the excel file. Major error can be seen on 3, 4 and 5 degree in 12g configuration as instead of 3, 4 or 5 degree I am getting  356, 357, 358 or 359 degrees.

    What I am suspecting is that the accelerometer values given by sensor are not correct. If this is the problem then can my sensor be damaged or faulty? 

    Community Moderator
    Community Moderator

    Re: BMI088 giving wrong accelerometer RAW data?

    Your data looks very suspicious to me. In the "3g" datalog, the values between -0.0102539 and 0.0100708 never appear. In LSB, this would mean a "gap" of over 2000LSBs where you never get those values.

    I just tested with a BMI088 shuttleboard and could not reproduce your issue, I would recommend that you investigate closely how you read the data and convert it to floating point values.

    For future support, please make sure that your datalog is directly in LSB format, to eliminate the possibility of the conversion being the problem.

    Member

    Re: BMI088 giving wrong accelerometer RAW data?

    Thanks a lot. Found problem in the conversion of the data from the sensor. Was using signed short int, which was causing the problem. I changed it to signed int and it solved my problem. Thanks for the help.   ^_^

    Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist