Bosch Sensortec Community

    cancel
    Showing results for 
    Search instead for 
    Did you mean: 

    BNO055 Fusion Data Spike

    canpinaremre
    New Poster

    BNO055 Fusion Data Spike

    Hardware : Gravity: BNO055+BMP280 intelligent 10DOF AHRS from DFRobot  & STM32F407VGT Discovery

    Method: Reading Euler angles using I2C

    Problem: There are spikes in reading data.

    Tests:

    1- Tried with another IMU (L3G4200D and LSM303DLHC) and I2C working perfectly fine. This means STM32F407VGT Discovery is OK.

    2- Tried other fusion outputs (Quaternion and Linear Acc) and reading spikes. So the problem is not about Euler registers.

    3- There is no vibration at all just using my hand to rotate very slowly sometimes faster. Speed doesn't change the results. I have always reading spikes.

    Files added:

    1- Excel table for my reading logs. (Obtained from STM Studio)

    2- 1 PNG images from STM Studio that show spikes.

    3- 1 PNG image from Excel table where spike can clearly observable.

    Questions:

    1- Is it a problem that occurs in any BNO055 or my BNO055 is damaged?

    2- What is the probable cause and how to avoid it?

    3- My goal is to use this IMU in Quadcopter. Any advice about using another model? I am not good with filters like Kalman so I have to have an IMU that calculates angles for me.

    This is my second post. The first one never answered. Please I need some answers.

    Emre,

    2 REPLIES 2
    BSTRobin
    Community Moderator

    Re: BNO055 Fusion Data Spike

    canpinaremre
    New Poster

    Re: BNO055 Fusion Data Spike

    Yes, sorry for copying the post. When there was no answer I want to declare the problem more clearly. Waiting for your solutions. Thank you.

    Emre,

    Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist