Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    Not Receiving Any Response on BMA253 MISO Line (SPI Communication Trouble)

    Not Receiving Any Response on BMA253 MISO Line (SPI Communication Trouble)

    New Poster

    Trying to communicate with BMA253 Shuttle Board. Using nRF52 DK and BMA2x2 API.

    I connect the VDD/VDDIO (3V3), GND, MISO, MOSI, SCK, /CS and PS (to gnd). I have also tried with the MISO pin floating.

    Screenshot from 2019-07-01 17-30-19.png


    Here are the signals scoped:

    Yellow: Clock, Green: MOSI, Blue: MISO, Pink: CS



    Does anyone have any suggestions? I have tried sending various messages. I've read that some devices start in suspend mode or the CS line has to  be raised to change chip from i2c to spi mode. Nothing has worked for me though.

    2 REPLIES 2

    Community Moderator
    Community Moderator

    1. BMA253 starts to normal power mode and there is no need to toggle CS pin to switch to the SPI mode.  the protocol selection is done by PS pin.  And it is start with 4 pin SPI mode by default if PS connect to GND.

    2. From your describtion, you connect VDD, VDDIO, MISO, MOSI, CS, SCK, PS and GND pin, this should be good enough

    3. please double check with SPI mode your host is using, we only support mode 0 and 3 in BMA253 side.

    4. Can you also show how you connect the pins to your host side and your power up sequence for our sensor?  

    The SPI communication of BMA253 should be straight forward after power on  

    Occasional Contributor

    BMA253, SPI only support mode 0(b00) & mode 3(b11), so please check which mode the master is applied.

    For BMA253, since the PS pin is pulled low, so no additional read/write is required to switch it to SPI mode. However, the PS pin should be kept low, from before BMA253 Power on reset.

    From the image of waveform, the CLK signal stopped after sending the 1st bytes (R+reg address), so the second byte(register value from BMA253) cannot be send out without clock. Please check the master side SPI.