Bosch Sensortec Community

    cancel
    Showing results for 
    Search instead for 
    Did you mean: 

    Orientation Error in Yaw of BNO055 in 9DOF Mode?

    A_Levy
    Established Member

    Re: Orientation Error in Yaw of BNO055 in 9DOF Mode?

    Aboslutley, ill let you know how it goes.

    A_Levy
    Established Member

    Re: Orientation Error in Yaw of BNO055 in 9DOF Mode?

    Hello BTS_Robin, Quick quetsion , how would that BNO055 stick actually help? we are trying to update the firmware to fix the CS calibration problem. So how would this exactly help? Even during tetsing how would it help?

    Thanks 

    BSTRobin
    Community Moderator

    Re: Orientation Error in Yaw of BNO055 in 9DOF Mode?

    Hello A_Levy,

    Actually, we tried to reproduce the problem you gave feedback with DD2.0+BNO055 shuttle board, BNO055 USB stick, but it failed to reproduce it. So we hoped you could test it with our reference HW and saw if you could reproduce it on our reference HW. Then we could do further analysis.

    A_Levy
    Established Member

    Re: Orientation Error in Yaw of BNO055 in 9DOF Mode?

    Hello BTS_Robin, 

    We have been working on updating the firmware of the BNO055 with the sample firmware updated that was provided by Vincent.

    However, we are running into an unforseen problem. When we attempt to stream the firmware update to BNO055, the BNO055 stops responding after roughly 250,000 Bites have been recieved. Do you have any idea why this is happening or how to fix this? 

    A_Levy 

    A_Levy
    Established Member

    Re: Orientation Error in Yaw of BNO055 in 9DOF Mode?

    Hello BTS_robin, 

    We have acquired the Bosch BNO055 development kit and shuttle baord. We have also updated the firmware of the BNO055. However, even with the bosch hardware, we are still seeing the same problem persist.

    As soon as the the BNO055 starts moving, the system calibration goes away from 3/3. I have attached a CSV file that is an example of the problem we are seeing. 

    Do you have any ideas what could be causing this or why this is happening?

    THank you, 

    Alevy

    Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist