Bosch Sensortec Community

    Sleep mode BMI160 not work

    Highlighted
    Established Member

    Sleep mode BMI160 not work

    Hi, 

    I have a problem to activate the power safe mode of the BMI160 sensor. I have setted these registers :

    Accelerometer low power :

    Register : (0x7E)

    Data : (0x12)

     

    Gyroscope suspend mode :

    Register : (0x7E)

    Data : (0x17)

     

    Magnetometer suspend mode :

    Register : (0x7E)

    Data : (0x18)

    When i set these registers i don't have error, but if i set these registers or not set the consumption of the my board not change, for example, the consumption remain the same 0.060 ampere indifferently if set the registers to imposted the suspend mode (Magnetometer  and Gyroscope) and low power mode (accelerometer). Why the consumption not change if i setted low power mode on the BMI160 sensor ?

    Another information:

    The communication i2c works correctly becuase i setted all other register nothing problems. With the sensor BNO055 i reduced the consumption without problems.

    Thanks you

    Thanks you

    3 REPLIES 3
    Highlighted
    Community Moderator

    Re: Sleep mode BMI160 not work

    Hello GMarco_Utech12,

    If you could ensure I2C communication worked currectly, you also needed to check undersampling, band width, ODR parameters setting in 0x40(ACC_CONF) register. Power consumption changes are also related to these parameters.

    Highlighted
    Established Member

    Re: Sleep mode BMI160 not work

    I don't setted the paramenters undersampling, band width, ODR parameters in 0x40(ACC_CONF) register. I left the default values on the register 0x40. How i must set these parameters for reduce the consuption at  the minimum ? 
    I must set its parameters also for magnetomenter and gyroscope for reduce the consuption at  the minimum of the BMI160 sensor ?

    Thanks you

    Highlighted
    Community Moderator

    Re: Sleep mode BMI160 not work

    Hello GMarco_Utech12,

    You should set a value(your acc_us, your acc_bwp, your acc_odr) to 0x40 for your application. By 0x40 register default value, acc_us was disable. acc_us should be set to 1 for low power mode.

    Please refer register configuration from data sheet:

    BMI160_0X40_ACC_CONF-1.png

    BMI160_0X40_ACC_CONF-2.png

    BMI160_Current_consumption-1.png

    BMI160_Current_consumption-2.png

    If you haven't used magnetomenter and gyroscope, you only needed to set them to suspend. If you want to use magnetomenter and gyroscope, you could set them to minimum current consumption according register settong from BMI160 data sheet.

     

    Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist