Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    bme 688 dev kit configuration

    bme 688 dev kit configuration

    New Poster


    I recently bought a BME688 x8 dev board with a separate huzzah32 board. I used the AI studio to generate my .bmeconfig file, then copied it onto my micro SD card and installed it. Using the latest BME_x8 software (v_1.5.0), I ran flash.bat to the COM port my board was connected to. However, the dev board's red LED was still flashing quickly, and no data was being stored. I tried using someone else's .config and .bmeconfig files as well, but that didn't work either. 

    If anyone has ideas as to why this might happen, any help would be greatly appreciated. I am a total newbie to this stuff, so I apologize if there's an obvious answer I'm missing.

    5 REPLIES 5

    Community Moderator
    Community Moderator

    Hello GMH2250,

    1.Program your board
    If you start with a new Adafruit HUZZAH32 board, which is not yet programmed, you can flash it by following these steps:

    After you program your board and power on for a while, you could find *.bmerawdata file in SD card.

    2.Generate config file
    Following BME AI-Studio user guide to generate config file.

    BME AI-Studio.pngBME AI-Studio video.png

    Hello BSTRobin,

    Thanks for the reply. I think I wasn't totally clear with what problems I'm having. I've already tried flashing it according to those directions, and it appears to be successful at first. I've attached a screenshot of the interface to show you what I mean. The problem is, even after I do that and allow it to sit for a day or two, the red LED still flashes quickly and no data is stored on the SD card. Just to be totally clear with the steps I went through to flash it, I

    1. Downloaded the dev-kit software to my PC
    2. Copy + pasted the .bmeconfig file to the SD card, and installed it into the dev kit
    3. Made sure the proper USB driver was installed
    4. Connected the board with a data capable micro USB cable
    5. Ran Flash.bat from my computer, selecting the COM port that the cable was attached to (Windows's Device Manager showed me COM5)
    6. Kept dev kit plugged in for two days, still no data on SD card and the LED was not blinking every two seconds, which told me that data was not being collected

    I hope that elucidates the situation for you. I've tried testing the battery, clearing the SD card and putting the .bmeconfig file back on it, flashing it again, and using the board's reset button, but none of those have worked. 

    Thanks again for the help

    Community Moderator
    Community Moderator

    Hello GMH2250,

    Unfortunately we haven't reproduced this problem. Normally, you will find *.bmerawdata file in SD card as you program the board and power on again.
    Do you use the official suite without any changes? Including SD card.

    I am having the exact same issue. Been thru the setup several times.  I even loaded the apk that works but when it does connect to the board says there is an Issue with SD. I have tried several formats and cards but result is the same each time.