Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    temperature values is always 0

    temperature values is always 0

    New Poster

    Hi ,


    I am trying to integrate BESEC software to interface BME680  with EFR32BG22(Cortex M33).I sucessfully integrate libalgobsec.a file for GCC cortex M33F into my project.The project get  compiled sucessfully without any error.

    I have problem with the output data from the BME680.The temperature value remain 0 all the time, and CO2,Iaq and breath values take quiet long time to show-up (initially they all shows 0 values)

    My program take reading every 3 sec. I am using simplicity studio IDE and GNU ARM v10.2.1 compiler.

    I susppect there is  someting wrong with bsec_init()(initialization in BESEC library) function .It looks like  temperature functionality of BME680 is not getting initialize properly.

    I am attaching the snapshot output console:

    Please help me to resolve this issue.


    Thank You



    30 REPLIES 30

    Hi franciskumar200, 


    He used gcc cortex ARM compile, it worked. But, actually we didn't test it yet for M33. 

    Please try in same way as he did.  (He tested BSEC library, not BSEC 2 library also) 

    If you want to request it for us, please visit as I asked you before. 

    I'm not sure whther we can provide or not, but you can get any information from us. 


    Hi Minhwan,

    Thanks for your response.

    I did the same with BEC first as per his calls and still the problem remains same. Library calls are not taken from bec lib.

    Is there any library compatibility? In earlier I added some other sensor related external library it is working. But the library integration process scope is not getting from your BEC lib.

    Until I get response the from Mr.Jimpin then I can understand Is there any cortex-M33 problem.




    Sorry for confusing. 

    I found the our supported platforms as below.

    and M33 is there, so should be okay with that 🙂 

    Thank you. 

    Hi Minhwan,

    Still my issue is not yet solved.

    I tried with other libraries, but there are still some issues.

    Is there any desktop standalone application which I can forward my GAS raw values to your BEC library? Will it give the GAS results?

    For example i am getting RAW values for GAS = 856789 ohm. should i get the actual GAS index in ppm while i pass this value to your BEC lib.



    HI Kumar, 


    Unfortuantely, we don't have standalone tool for BSEC library. 

    Need to check in MCU side. What is the your current status? 

    Can you build your project? 

    If you can build your project, where you can't get the value? Same as before? Could you get any error message from BSEC example code? 

    Thank you.