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1 Introduction  

The BHI260AB is a family of ultra-low power smart sensor hubs consisting of Bosch Sensortec’s 
new, programmable 32-bit microcontroller (Fuser2), a state-of-the-art 6-axis IMU and a powerful 
software framework containing pre-installed sensor fusion library BSX4 and other sensor 
processing software within a small 44 pad LGA package. 
 
The Fuser2 Core is configurable to operate at 20 MHz (Long Run mode) and 50 MHz (Turbo 
mode). It can boot from a wide variety of hosts, ranging from a small Cortex-M0TM MCU up to 
multicore application processors, while it has also the ability to run standalone, when booting 
from an attached flash memory. 
 
In combination with its wide connectivity and extendibility, the BHI260AB becomes a versatile 
and ideal solution when it comes to always-on sensor processing at ultra-low power 
consumption.  
 
The BHI260AB is the second generation of smart sensor hub compared to the first generation 
BHI160 and BHI160B smart sensor hubs. The comparison table is as shown in Table 1. 
 
Table 1 comparison between BHI160B and BHI260AB 

 
 
Every time when BHI260AB is powered on, the RAM patch with the filename “*.fw” needs to be 
downloaded into BHI260AB. Then the host needs to enable one or multiple virtual sensors with 
selected output data rate (ODR). Then BHI260AB will automatically output results continuously. 
 
This document shows instructions on how to play with the BHI260AB shuttle board to quickly 
evaluate BHI260AB. 
 
 
 
 
 
 
 

Parameter BHI160B BHI260AB
Dimensions 3 mm x 3 mm x 1 mm 3.6 mm x 4.1 mm x 0.83 mm 

Processor Clock Speed 10 MHz 20 MHz (long run) or 50 MHz (turbo)

Primary host interface type (I2C, 3.4MHz) (I2C, 3.4MHz)/(SPI, 50MHz)

Secondary sensor interface One 
(I2C, 400Hz)

Up to four
(I2C, 1MHz)/(SPI, 50MHz)

Memory 48KB RAM, 96KB ROM 
no flash support

256KB RAM, 144KB ROM
up to 8MB external flash

Max. Output sample rate (Hz) 200Hz 800Hz

Integrated Algorithms  State of the art BSX3 Sensor Fusion

Enhanced BSX4 Sensor Fusion with :
• Higher data rates
• Configurability (e.g. Low Power options)
• Additional Virtual Sensors

Programmability
Programmable by customer

Sensor software framework support
Metaware compiler support

Programmable by customer
Sensor software framework and OpenRTOS support

Metaware compiler and GCC support



 

 
Technical Document 

How to play with BHI260AB shuttle board 

d l t 
 

 

Page 4 

Confidential 

 
 

  July 2019                                                                                         Bosch Sensortec 

© Bosch Sensortec GmbH reserves all rights even in the event of industrial property rights. We reserve all rights of 
disposal such as copying and passing on to third parties. BOSCH and the symbol are registered trademarks of Robert 
Bosch GmbH, Germany.   

 Note: Specifications within this document are subject to change without notice. 
 
 

 
   

2 Hardware 

The hardware includes one APP2.0 base board, one BHI260AB shuttle board and one micro 
USB cable as shown in Figure 1. 
 

 
 

Figure 1 APP2.0 base board and BHI260AB shuttle board 
 
Since BHI260AB operates at 1.8V only and APP2.0 base board uses 3.3V, a level shifter is 
required to convert 3.3V to 1.8V for BHI260AB power supply and digital interface.  
 
On the level shifter board, please place the jumper at the location for SPI interface because the 
following software uses SPI interface by default. 
 
APP2.0 base board can be purchased at https://www.mouser.com/ProductDetail/Bosch-
Sensortec/Application-
Board?qs=sGAEpiMZZMuqBwn8WqcFUoBr6H0DPHbmmKD1%2FZpnPHTNXN07wcSwfQ%3
D%3D.  
 
APP2.0 base board schematics is available online at https://ae-
bst.resource.bosch.com/media/_tech/media/application_board_2_0/BST-DHW-AN001-
01_APP2_0_Hardware_Description_.pdf.  
 
BHI260AB shuttle board can be requested through local sales representative and its schematics 
is available online at https://ae-
bst.resource.bosch.com/media/_tech/media/shuttleboard_flyer/BST-DHW-FL026.pdf. On 
BHI260AB shuttle board, Bosch BMM150 and AKM AK09915 magnetometers are installed. 
Bosch 3-in-1 environmental sensor BME280 (temperature, air pressure and humidity) is also 
installed.  
 
 
 

Micro USB port 

APP2.0 base board 

BHI260AB 
shuttle board 

Level shifter 
board 

Jumper location 
for SPI interface 

ON/OFF switch 

https://www.mouser.com/ProductDetail/Bosch-Sensortec/Application-Board?qs=sGAEpiMZZMuqBwn8WqcFUoBr6H0DPHbmmKD1%2FZpnPHTNXN07wcSwfQ%3D%3D
https://www.mouser.com/ProductDetail/Bosch-Sensortec/Application-Board?qs=sGAEpiMZZMuqBwn8WqcFUoBr6H0DPHbmmKD1%2FZpnPHTNXN07wcSwfQ%3D%3D
https://www.mouser.com/ProductDetail/Bosch-Sensortec/Application-Board?qs=sGAEpiMZZMuqBwn8WqcFUoBr6H0DPHbmmKD1%2FZpnPHTNXN07wcSwfQ%3D%3D
https://www.mouser.com/ProductDetail/Bosch-Sensortec/Application-Board?qs=sGAEpiMZZMuqBwn8WqcFUoBr6H0DPHbmmKD1%2FZpnPHTNXN07wcSwfQ%3D%3D
https://ae-bst.resource.bosch.com/media/_tech/media/application_board_2_0/BST-DHW-AN001-01_APP2_0_Hardware_Description_.pdf
https://ae-bst.resource.bosch.com/media/_tech/media/application_board_2_0/BST-DHW-AN001-01_APP2_0_Hardware_Description_.pdf
https://ae-bst.resource.bosch.com/media/_tech/media/application_board_2_0/BST-DHW-AN001-01_APP2_0_Hardware_Description_.pdf
https://ae-bst.resource.bosch.com/media/_tech/media/shuttleboard_flyer/BST-DHW-FL026.pdf
https://ae-bst.resource.bosch.com/media/_tech/media/shuttleboard_flyer/BST-DHW-FL026.pdf


 

 
Technical Document 

How to play with BHI260AB shuttle board 

d l t 
 

 

Page 5 

Confidential 

 
 

  July 2019                                                                                         Bosch Sensortec 

© Bosch Sensortec GmbH reserves all rights even in the event of industrial property rights. We reserve all rights of 
disposal such as copying and passing on to third parties. BOSCH and the symbol are registered trademarks of Robert 
Bosch GmbH, Germany.   

 Note: Specifications within this document are subject to change without notice. 
 
 

 
   

3 Software 

In order to evaluate BHI260AB shuttle board, there are three software available, 
• Development Desktop 2.0 (DD2.0) 
• COINES v2.0 
• ARC GNU IDE 2019.03-rc2 Eclipse 

Their differences are as shown in Table 2. 
 
Table 2 functionalities of these three SW 

Functionalities DD2.0 COINES ARC GNU 
Real-time waveforms Yes No No 
Log data into a CSV file Yes Yes Yes 
Low level programming No Yes Yes 
Develop and test own algorithm No Yes Yes 
Generate customized RAM patch No No Yes 

 
3.1 DD2.0 SW 

DD2.0 SW can be downloaded online at https://ae-
bst.resource.bosch.com/media/_tech/media/development_desktop_software/DevelopmentDeskt
op20_V3.19.exe. After installation users are able to download the RAM patch into BHI260AB, 
enable virtual sensors, view real-time results and log results into a CSV file. The instructions are 
as shown below. 
 

• Connect micro USB cable from APP2.0 base board to PC USB port. Switch on APP2.0 
base board. 
 

• Launch DD2.0 SW and DD2.0 will automatically recognize the BHI260AB shuttle board. A 
dialog window will be popped up asking to download the RAM patch as shown in Figure 2. 

 

 
 

Figure 2 RAM patch download dialog 
 

• Click the “…” button and select the “Bosch_LGA_SHUTTLE_BMI160_BMM150.fw” that is 
located in the “C:\Program Files\Bosch Sensortec\Development Desktop 

https://ae-bst.resource.bosch.com/media/_tech/media/development_desktop_software/DevelopmentDesktop20_V3.19.exe
https://ae-bst.resource.bosch.com/media/_tech/media/development_desktop_software/DevelopmentDesktop20_V3.19.exe
https://ae-bst.resource.bosch.com/media/_tech/media/development_desktop_software/DevelopmentDesktop20_V3.19.exe
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2.0\Firmware\BHI260\RAM Images” folder. Then click the “Download” button. After a short 
while users should see the text “BHI260 firmware is downloaded successfully”. Then close 
this dialog. 
 

• Next step is to enable one or multiple virtual sensors by clicking the “Virtual Sensor” tab 
on the top right corner of DD2.0 SW. For example, from the “Virtual Sensor” dropdown list 
select “Gravity (Non-Wakeup)” and then click “Write Info” tab. Select 100Hz from the 
“Sample Rate” dropdown list and then click “Write” button. 

 
• Similarly enable virtual sensor “Linear Acceleration (Non-Wakeup)” and “Orientation (Non-

wakeup)” with the same 100Hz sample rate and click the “Write” button.  
 

• Click “System” tab on the top right and select the above three virtual sensors from Plot1, 
Plot2 and Plot3 respectively. Then click “Refresh” button to check if each physical sensor 
is active or not from their “Power Mode” status respectively. 

 
• Now click “Start Streaming” button on the bottom left to see the waveforms in real-time by 

rotating the APP2.0 base board with BHI260AB shuttle board plugged in. When moving on 
a flat surface back and forth, linear acceleration is changing in Plot2, while gravity vector 
in Plot1 remains the same as shown in Figure 3.  

 

 
 

Figure 3 BHI260AB virtual sensors’ waveforms 
 

• Click “Panels -> Data Export” a dialog window will pop up as shown in Figure 4. The 
enabled virtual sensors’ results can be saved into a CSV file. 
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Figure 4 Log data into a CSV file 
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3.2 COINES SW 

COINES v2.0 SW can be downloaded online at https://ae-
bst.resource.bosch.com/media/_tech/media/coines/COINES_v2.0_Windows.exe. After 
installation users are able to find the folder C:/Windows/COINES/v2.0 as shown in Figure 5.  
 
COINES ("COmmunication with INertial and Environmental Sensors") provides a low-level 
interface to APP2.0 base board and each sensor shuttle board. Users can access MEMS 
sensors through a C interface. COINES can be used with the SensorAPI of the sensor. The 
SensorAPI is available at https://github.com/BoschSensortec. Source code of sample 
applications and SensorAPI are provided with the COINES library as a package. Users can 
modify, compile and run the sample applications. However, users cannot create their own virtual 
sensors with their own algorithms and then generate customized BHI260AB RAM patches.  
 

 
 

Figure 5 COINES folder 
 

One example of using COINES together with the APP2.0 base board and BHI260AB shuttle 
board is as shown below. 
 

• Go to folder C:\COINES\v2.0\examples\c\bhy2\rotation_vector in Windows File Explorer. 
Then press and hold “Shift” key on the keyboard and then right click the mouse. Select 
“Open PowerShell window here” as shown in Figure 6.  

https://ae-bst.resource.bosch.com/media/_tech/media/coines/COINES_v2.0_Windows.exe
https://ae-bst.resource.bosch.com/media/_tech/media/coines/COINES_v2.0_Windows.exe
https://github.com/BoschSensortec
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Figure 6 COINES example folder 
 

• Type mingw32-make and press Enter key. The exe file is generated as shown in Figure 7. 

 
 

Figure 7 COINES compiling to EXE file 
 

• Type .\bhy2_rotation_vector.exe and press Enter key. The RAM patch will be downloaded 
to BHI260AB shuttle board and COINES lists all the virtual sensors. Then COINES 
displays rotation vector quaternions x, y, z, w continuously as shown in Figure 8. 
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Figure 8 COINES example results 
 

• Users can modify “bhy2_rotation_vector.c” file and compile it again for further evaluation. 
COINES has its own editor IDE on the desktop of the PC after installation.  
  

• If user’s PC is Windows 10 OS x64, then please download TDM64-GCC-5.1.0-2 online at 
https://sourceforge.net/projects/tdm-gcc/files/TDM-GCC%20Installer/tdm64-gcc-5.1.0-
2.exe/download. And then install it because it will be used to compile the code in COINES.  

 
 
 
 
 
 
 
 

https://sourceforge.net/projects/tdm-gcc/files/TDM-GCC%20Installer/tdm64-gcc-5.1.0-2.exe/download
https://sourceforge.net/projects/tdm-gcc/files/TDM-GCC%20Installer/tdm64-gcc-5.1.0-2.exe/download
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3.3 ARC GNU IDE 2019.03-rc2 Eclipse 

The ARC GNU IDE 2019.03-rc2 for Windows can be downloaded online at 
https://github.com/foss-for-synopsys-dwc-arc-processors/toolchain/releases/download/arc-
2019.03-rc2/arc_gnu_2019.03-rc2_ide_win_install.exe. It is all-in-one IDE for BHI260AB that 
allows users to develop their own algorithms, generate their own RAM patch together with the 
BHI260AB SDK and test the code together with COINES SW as a terminal. 
 
The BHI260AB SDK “BHI260_SDK_Installer_V1.0.0.exe” is available under NDA. Please 
contact local sales representative for the NDA before BST FAE (field application engineer) 
sends the BHI260AB SDK to the user. 
 
The following instructions show how to use ARC GNU IDE to develop customized BHI260AB 
RAM patch.  
 
The example here is to create a new virtual sensor so called “Lean Device Orientation (LDO)” 
which uses BHI260AB accelerometer data to display which axis is pointing to sky. For example, 
Z+ means Z axis is pointing to sky and Z- means Z axis is pointing to ground. 
 

• Assume the ARC GNU IDE, BHI260 SDK and COINES v2.0 have been installed on a 
Windows x64 PC.  
 

• Launch ARC GNU IDE and click menu “File -> Import…”. Then select “Existing Code as 
Makefile Project” and click “Next” button. Then click “Browse” button to locate the BHI260 
SDK folder on your PC and click “Finish” button.  

 
• Repeat the above step to import C:\COINES\v2.0\examples\c\bhy2\bhy2cli folder. Bhy2cli 

is a command line interface tool between PC and BHI260AB shuttle board. Users can 
open a Terminal in ARC GNU IDE and type commands there to see the results. 

 
• In ARC GNU IDE click “BHI260_SDK” on top left and then click menu “Project -> 

Properties”. Click “C/C++ Build” on the left of the popup window and type “build.bat” on the 
Build command Edit box as shown in Figure 9. 

 

 
 

Figure 9 Project Properties Builder Settings 

https://github.com/foss-for-synopsys-dwc-arc-processors/toolchain/releases/download/arc-2019.03-rc2/arc_gnu_2019.03-rc2_ide_win_install.exe
https://github.com/foss-for-synopsys-dwc-arc-processors/toolchain/releases/download/arc-2019.03-rc2/arc_gnu_2019.03-rc2_ide_win_install.exe
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• Then click “Behavior” tab and make the configurations as shown in Figure 10. 
 

 
 

Figure 10 Project Properties Behavior 
 

• Click menu “Windows -> Show View -> Terminal”. A new “Terminal” tab will show up. 
Then click the “Open a Terminal” icon on the right side and click “OK” button as shown in 
Figure 11. 
 

 
 

Figure 11 Terminal configuration 
 

• Now ARC GNU IDE is ready to use.  
 
The following three steps show how to create own virtual sensor and generate own RAM patch 
*.fw file. 
 

• Open the “boards” folder under BHI260_SDK project in ARC GNU IDE. Copy and paste 
“Bosch_SHUTTLE_BHI260_BMM150.cfg” file and then rename it as 
“Bosch_SHUTTLE_BHI260_BMM150_LDO.cfg”. At the end of this file, add below two 
lines as shown in Figure 12. 
 

 131, -1.000000 # custom LDO data source 
 132, -1.000000 # custom LDO algo 
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Figure 12 Create a new *.cfg file 
 

• Double click the file “config.7189_di03_rtos.cmake” under the “common” folder. Add the 
line Bosch_SHUTTLE_BHI260_BMM150_LDO as shown in Figure 13. 

 

 
 

Figure 13 Add the new cfg board name 
 

• In the “drivers” folder two driver source codes have been implemented as an example: 
VirtBSXCustomAccelDataSource and VirtBSXLeanDeviceOrientation. They need to be 
added under the ENABLED_DRIVERS in the file “config.7189_di03_rtos.cmake” as shown 
in Figure 14. 
 
The VirtBSXCustomAccelDataSource driver defines the accelerometer data is from the 
Fuser Core2 BSX4 sensor fusion library.  
 
The VirtBSXLeanDeviceOrientation driver is how the new own customized algorithm is 
implemented.  
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Figure 14 Add the two new custom drivers’ names 
 

• Click menu “Project -> Build All”. It should show 0 errors. Then click the “release -> gccfw” 
folder and the “Bosch_SHUTTLE_BHI260_BMM150_LDO.fw” has been generated there. 

 
The following steps show how to test the new virtual sensor performance. 
 

• In Terminal type the following, 
bhy2cli -b <path_to_release_gccfw_folder>/Bosch_SHUTTLE_BHI260_BMM150_LDO.fw 
The new RAM patch will be downloaded into BHI260AB shuttle board as shown in Figure 
15. 
 

 
 
Figure 15 bhy2cli –b command to download RAM patch to BHI260AB shuttle board 
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• In Terminal type bhy2cli –i command and press Enter key. It will list all the Sensor IDs as 
shown in Figure 16. Sensor ID 160 is the new virtual sensor that is just implemented.  

 

 
 

Figure 16 bhy2cli –i command to list all sensor IDs 
 

• In Terminal type bhy2cli -a 160:LDO:nw:2:c:c -c 160:10 command and press Enter key. It 
will display the results at 10Hz when the BHI260AB shuttle board is facing different 
orientations as shown in Figure 17. 

 

 
 

Figure 17 bhy2cli –a command to show results 
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4 Legal disclaimer 

4.1 Engineering samples 

Engineering Samples are marked with an asterisk (*) or (e) or (E). Samples may vary from the 
valid technical specifications of the product series contained in this data sheet. They are 
therefore not intended or fit for resale to third parties or for use in end products. Their sole 
purpose is internal client testing. The testing of an engineering sample may in no way replace 
the testing of a product series. Bosch Sensortec assumes no liability for the use of engineering 
samples. The Purchaser shall indemnify Bosch Sensortec from all claims arising from the use of 
engineering samples. 
 
4.2 Product use 

Bosch Sensortec products are developed for the consumer goods industry. They may only be 
used within the parameters of this product data sheet. They are not fit for use in life-sustaining 
or security sensitive systems. Security sensitive systems are those for which a malfunction is 
expected to lead to bodily harm or significant property damage. In addition, they are not fit for 
use in products which interact with motor vehicle systems. 
 
The resale and/or use of products are at the purchaser’s own risk and his own responsibility. 
The examination of fitness for the intended use is the sole responsibility of the Purchaser.  
 
The purchaser shall indemnify Bosch Sensortec from all third party claims arising from any 
product use not covered by the parameters of this product data sheet or not approved by Bosch 
Sensortec and reimburse Bosch Sensortec for all costs in connection with such claims. 
 
The purchaser must monitor the market for the purchased products, particularly with regard to 
product safety, and inform Bosch Sensortec without delay of all security relevant incidents. 
 
4.3 Application examples and hints 

With respect to any examples or hints given herein, any typical values stated herein and/or any 
information regarding the application of the device, Bosch Sensortec hereby disclaims any and 
all warranties and liabilities of any kind, including without limitation warranties of non-
infringement of intellectual property rights or copyrights of any third party. The information given 
in this document shall in no event be regarded as a guarantee of conditions or characteristics. 
They are provided for illustrative purposes only and no evaluation regarding infringement of 
intellectual property rights or copyrights or regarding functionality, performance or error has 
been made. 
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5 Document history and modification 

 
Rev. No Chapter Description of modification/changes Date 

1.0  Document creation July 18th, 2019 
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