Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BME688 connection to Android App

    BME688 connection to Android App

    Established Member


    I am trying to use the BME688 Andriod APP that was recently released. The App is able to connect to the BME 8x board via bluetooth.  The SD card with the config file is present. (i.e it is logging data). but right after the app connects, i get this msg on the APP :

    "Could not start sensor. response code: BSEC_CONFIG_MISSING"

    if i look at the SD card and open a raw data file it creates (its flashed with the bme68x_demo_sample.ino.bin ) - i see this header.. as a appVersion of 0.7.4 not sure if this works with the App that i downloaed for the Andriod. 

    "configHeader": {
    "dateCreated": "2020-10-20T08:54:10.804Z",
    "appVersion": "0.7.4",
    "boardType": "board_8",
    "boardMode": "heater_profile_exploration",
    "boardLayout": "grouped"
    } ....

    i have a *.bmeconfig in the SD card. so not sure what else is needed. again no documention etc. so its very tiny bit frustrating. 



    39 REPLIES 39

    Hello Minhwan,

    the linked solution doesn't work for me. Location Services (and the relevant permissions) were already active for the app.

    Best regards, Sebastian

    Community Moderator
    Community Moderator

    Hello all, 


    Sorry for inconvinience. 

    Could you please let me know which version are you using for android apk? 

    I'm using BME688_Demo_v1.1.2.apk

    If you use same one, please delete all configuration files and use files in config zip file. 

    I tested today, and it worked. 


    Hello Minhwan,

    thanks, it seems like the config files were the problem. When I'm using the ones you provided it does work, both using the App v1.1.2 and v1.1.3.

    Since your configs were generated with the AI-Studio 1.5.5 (instead of the newest v1.6.0 that I tried to use), is this older version still anywhere available to download?

    Thanks, Sebastian

    Community Moderator
    Community Moderator



    I tested today with latest version in website ( v1.6.0 AI studio + v1.5.0 dev kit ) 

    And, I faced same issue with you. 

    The reason is probably not matched each version. I'm going to let our team know and back to you soon. 

    Currently, only latest version is available for website, regarding old version download, I can't upload since it over 50MB. 

    Please wait for this issue a little bit. 

    Thank you for your patience. 

    I was able to defeat this error by copying both files (2021_04_27_13_53_BoardConfiguration.bmeconfig and 2021_04_28_08_35_bsec_h2s_nonh2s_2_0_6_1 .config) to the SD card and reflashing the board with firmware bme688_x8board_v1-5-0.