Bosch Sensortec Community

    cancel
    Showing results for 
    Search instead for 
    Did you mean: 

    BMI270 accelerometer configuration not giving correct accelerometer data

    BMI270 accelerometer configuration not giving correct accelerometer data

    kenadams
    New Poster

    Hi all, 

    I am trying to configure BMI270 in low power mode and I followed the steps given in the datasheet under the quick start section. I want to use the average values of the accelerometer data for 32 or 64 samples. And I guess we can only get the average in low-power mode. 

    The problem I am facing is, that after the device is in Low power mode, I am getting the accelerometer data as incorrect values. 

    for +- 2g and +-4g ACC_RANGE, I get the 1g reading as 2047 and 4087 respectively. Sometimes the accelerometer data is OFF by factor 4. According to the datasheet, the values should be 16384 and 8192 respectively. 

    My config settings for low power mode:

    • PWR_CTRL
      • ACC_EN = 1
      • GRY_EN, TEMP_EN & AUX_EN = 0
    • ACC_CONF
      • ACC_BWP = 0x02         // as the  datasheet says to keep it to "2 repetitions" and hope 0x02 is correct
      • ACC_FILTER_PREF = 0
      • ACC_ODR = 50 Hz
    • PWR_CONF
      • ADV_POWER_SAVE = 1
      • FIFO_SELF_WAKEUP = 1
      • FUP_EN = 0

    And then I read the accelerometer data and this puts the device in low power mode.

    Now, I again change the configuration of the accelerometer ACC_CONF  to set ACC_BWP for 32 samples and set ACC_ODR for 100 or 200 Hz, and then when I read the data the accelerometer data is OFF by some factor of 2 or 4. And I am not sure how to resolve this problem.

    I tried changing the ACC_ODR and ACC_BWP and tried all combinations but the data is not correct. i

    for only two cases I got the correct data which was for

    1. ACC_RANGE = 2g,    ACC_CONF ->ACC_BWP =  32 samples,    ACC_CONF->ODR = 100 Hz
    2. ACC_RANGE = 4g,    ACC_CONF ->ACC_BWP =  16 samples,    ACC_CONF->ODR = 200 Hz

    And I do not understand why is this the case. For only two cases I get the data correct and for all others, the data is OFF by some factor. 

    Can someone please help me with that? Thanks  🙂 

     

     

    0 REPLIES 0
    Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist