Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BME688 connection to Android App

    BME688 connection to Android App

    Established Member


    I am trying to use the BME688 Andriod APP that was recently released. The App is able to connect to the BME 8x board via bluetooth.  The SD card with the config file is present. (i.e it is logging data). but right after the app connects, i get this msg on the APP :

    "Could not start sensor. response code: BSEC_CONFIG_MISSING"

    if i look at the SD card and open a raw data file it creates (its flashed with the bme68x_demo_sample.ino.bin ) - i see this header.. as a appVersion of 0.7.4 not sure if this works with the App that i downloaed for the Andriod. 

    "configHeader": {
    "dateCreated": "2020-10-20T08:54:10.804Z",
    "appVersion": "0.7.4",
    "boardType": "board_8",
    "boardMode": "heater_profile_exploration",
    "boardLayout": "grouped"
    } ....

    i have a *.bmeconfig in the SD card. so not sure what else is needed. again no documention etc. so its very tiny bit frustrating. 



    39 REPLIES 39

    Thanks a lot, i have tested with 1.5.0 and seems you are right i should stick with latest 1.5.5 only as well as AI studio and android app latest versions. On android app i do get scanning and i still not sure why in app i see:

    1) Label1 only showing and not my trained classes Labels.

    2) Testing and  Environment buttons are greyed out. What are these ? How to run my algorithm test in real time ?

    3) Label button shows 4 Labels: Label1,Label2,Label3,Label4

    Content of SDcard attached.

    Thank You for the help


    Community Moderator
    Community Moderator

    Hi Kareig, 


    You need to make label again in our app. We don't send class name to app. Sorry for inconvinience. 

    Once you put your config file and bmeconfig in your SD card and connect to app, it should work automatically. 

    You can check a label what you trained. 

    Thank you. 

    Occasional Visitor

    I got the dev board to connect to the app. The app have the "Testing" and "Enviroment" greyed out. Are those function available for use? 

    Community Moderator
    Community Moderator

    After you download  demo for x8 array board, it should work 

    Please check our quick guide :

    After you connect, you should check the specific gas. 

    Established Member

    I have the same problem as some reported in this thread, grayed-out "Testing" and "Environment" menu item in the Android App (see attached screenshot)! What I did:

    • downloaded the .apk file form Bosch and installed it on an Android 13 device
    • downloaded the Arduino binary from Bosch and flashed it to the Feather
    • made an .bmeconfig file with AI-Studio, copied it to the SD card
    • gathered raw data from two sources
    • imported this data in AI Studio and made an algorithm
    • exported the .config file to the SD card
    • connected the Android device with the Feather
    • but still "Testing" and "Environment" is grayed-out

    What I tried also:

    • copy not only the .config file to the SD card but all files provided by AI-Studio (.aiconfig, .c, .h) but still the same
    • using the files
      2022_06_23_17_49_BoardConfiguration.bmeconfig and
      provided by Bosch from the zip
      but still the same, no working "Testing" and "Environment" menu item
    • instead using files here posted from BME688_x8Board_v1.5.0:
      2021_04_27_13_53_BoardConfiguration.bmeconfig and
      2021_04_28_08_35_bsec_h2s_nonh2s_2_0_6_1 .config,
      -> not working
    • installing the Feather via source, but I thought it is more secure to use the tested function and lib versions from Bosch

    My software versions:

    • AI Studio 1.7.1,
    • Android App 1.1.3:
      • btw. in the App's about section is written: App version 1.1.3, Firmware version 1.5.0,
      • incompatible with Arduino BME688 dev software 1.5.5 ??
    • Arduino binary: BME688_x8Board_v1.5.5
      • tested with .bmeconfig and .config from this archive

    Is there any inconsistancy between the Android App and the Arduino firmware so that "Testing" and "Environment" are not working. Do I have to copy additional files beside .bmeconfig and .config to the SD?

    I'm really out of additional ideas and solution to fix that problem, is the function already implemented in the Android version or only available in the iOS version?