Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BME688 connection to Android App

    BME688 connection to Android App

    Established Member


    I am trying to use the BME688 Andriod APP that was recently released. The App is able to connect to the BME 8x board via bluetooth.  The SD card with the config file is present. (i.e it is logging data). but right after the app connects, i get this msg on the APP :

    "Could not start sensor. response code: BSEC_CONFIG_MISSING"

    if i look at the SD card and open a raw data file it creates (its flashed with the bme68x_demo_sample.ino.bin ) - i see this header.. as a appVersion of 0.7.4 not sure if this works with the App that i downloaed for the Andriod. 

    "configHeader": {
    "dateCreated": "2020-10-20T08:54:10.804Z",
    "appVersion": "0.7.4",
    "boardType": "board_8",
    "boardMode": "heater_profile_exploration",
    "boardLayout": "grouped"
    } ....

    i have a *.bmeconfig in the SD card. so not sure what else is needed. again no documention etc. so its very tiny bit frustrating. 



    39 REPLIES 39


    Thanks for the instructions to connect the BME688 Dev kit to the app, it worked well. However, when the bluetooth is activated, the data is not saved to the SDcard correctly. The data is saved randomly and splited into small files of 7 ko which cannot be used by the BME AI Studio software. Could you help me solve this problem?

    Thank you

    Community Moderator
    Community Moderator

    Hello Amelie, 


    When you run the android application, that means you already have your own data. 

    Therefore, if you want to gather data, please use bme688 dev kit without app. 


    Occasional Visitor

    Hi there,

    I hope I'm not to late.
    I can't get the app to work as well with the same error message.

    Actually I alread tried reflashing the ESP32 but this didn't help.
    The only conf+bmeconf which work are the ones provided with the BME688_x8Board_v1.5.0 software folder.

    But of course I'd like to train and use my own data and conf and not only detect H2.

    Is the older Version of AI Studio available somewhere? 
    Version 1.5.5 seems to work just finde with 1.5.0 board software.

    Best regards


    I just downloaded latest softare from bosch.

    x8Board record raw data fine, i also can connect to android app but on the app "Testing" is greyed out and i cant try out how trained algorithm works but android app shows some real time data being scanned.

    I suppose it is due to that i should be flashing BME688_x8Board_v1.5.0 on x8Board and not latest BME688_x8Board_v1.5.5 because android app about says firmware 1.5.5.

    Could you please kindly share somewhere ?


    Community Moderator
    Community Moderator

    Hi kareig, 


    Yes, we recommend to keep using latest version and it's same for AI studio feature as well. 

    Here is the v1.5.0. 

    But latest version is as below for your information. 

    BME688 dev kit - v1.5.5

    BME688 dev kit app for Android - v.1.1.3

    BSEC 2 lib - V2.2.0.0 (Therefore, we reommcned to create v. config file using AI studio) 

    Thank you.