Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BMP581 I3C Not Working

    BMP581 I3C Not Working

    New Poster

    I can get BMP581 to work with I2C and SPI, but not I3C.
    Attached is the screenshot for sending a SETDASA command.
    It returned NACK for static address.
    The static address is 0x46.
    I am using SparkFun Pressure Sensor - BMP581 (Qwiic).
    What do I missed?



    8 REPLIES 8

    Community Moderator
    Community Moderator

    Hi choongay,

    With your host FPGA, has it successfully communicated with other I3C slave devices?

    Hi, Robin.

    No, I don't have other I3C slave device.

    Community Moderator
    Community Moderator

    Hi choongay,

    The waveform of your host's I3C does not meet the I3C specification. We suggest that you refer to the I3C specification to communicate with BMP581.

    I3C spec.pngCustomer's I3C waveform.png

    Hi, Robin.

    I still face other issue after fixing the repeated start.

    I am getting a response 0x63 for GETBCR command. 

    This is not an expected value.

    Is it a valid command to read the BCR using static address?



    I did tried SETDASA but unable to set the dynamic address as I cannot communicate with the sensor using dynamic address.

    The oscilloscope shows unexpected ACK on address which confuse me.

    The screenshot shows I am using 0x13.

    The first digit may be ignored by the sensor, I am not sure.

    But I did tried with other value also such as 0x12.


    Another question is does the I3C works with pull up resistors?

    I am using 100KHz - 200KHz and my setup cannot disable the pull up on the fly.


    Thank you very much.