Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    Problem with COINES v2.7.0 libusb on macOS (arm64)

    Problem with COINES v2.7.0 libusb on macOS (arm64)

    New Poster


    I've successfully got COINES v2.7.0 to build (all the included examples) on a Windows machine, using Cygwin. I need it to also run on my macbook (M1 chip, arm64), which should be supported, but I keep hitting a problem with libusb. 

    It seems COINES only comes with a libusb-1.0.a for mingw (x84 and x64). So, I cloned the libusb from Github and built the .dylib specifically for "All Mac" as per the guidelines here:

    I then copied the built libusb-1.0.0.dylib into the libusb-1.0 folder of COINES, and tried to recompile but I still get the same error: 

    ld: library not found for -lusb-1.0

    clang: error: linker command failed with exit code 1 (use -v to see invocation)

    Disclaimer: I'm not a software engineer, have limited DIY experience with makefiles. 

    Best wishes,


    9 REPLIES 9

    Community Moderator
    Community Moderator

    Hi oggyshooy,

    Do you mean you installed COINES_v2.7.2_MacOS_Beta(download from and compiled Coines example code, and got the following error information?
    ld: library not found for -lusb-1.0
    clang: error: linker command failed with exit code 1 (use -v to see invocation)

    Hi BSTRobin

    Yes, indeed I downloaded the shell script from that link you posted. After running, it actually installs on my system as "COINES v2.7.0", even though I can see the install shell script says 2.7.2. 

    I just tried reinstalling, and I guess the default install location path has not been updated in the install shell script. Nonetheless, running the shell script fails with this output:

    [ MAKE ] coines-api
    [ AR ] libcoines-pc.a
    [ LD ] app_switch
    ld: library not found for -lusb-1.0
    clang: error: linker command failed with exit code 1 (use -v to see invocation)
    make: *** [app_switch] Error 1
    COINES installed successfully!

    I guess the problem is that COINES doesn't come with libusb for macOS, only mingw. Perhaps there's a way to force it to use my system's installation (I definitely have libusb installed via homebrew).