Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BME 688 not reading data

    BME 688 not reading data

    New Poster


    I followed all the steps from the BME 688 development kit but unfortunetly after connecting the board to power with usb the red light keeps flashing fast, and pressed the button for gas reading but after a while when I put the SD card into the PC the only files there are the configuration files and there is no data read from sensor. I have installed all 3 softwares from the website as well : 

      1. BME688 Dev kit Software (v.1.5.0)
      2. BME688 Dev Android App (v.1.1.3)
      3. AI studio (v1.6..0

    It will be great if you can let me know what we can do to try to get some data ? 



    Neeka Garoosi

    8 REPLIES 8

    i loaded the 1.5 version of flash.bat and this is the result: led is still flashing fast



    guys is there anyone able to help me please....

    this flashing red light is making me crazy, iunderstand its probably me doing something but just need help finding the problem.

    i have 3 different kits + 10 sd cards variety of size + 4 different pc/laptops

    tried formatting it with different size cards and formats, fat32,ntfs etc..

    tried the Arduino IDE route and still get the same error-2 or sd card not found or sensor not found

    ive used the header pins, breadboards, jumper wires still same red light

    i have got the board working with other sensors (SGP30) and it works perfectely so i know the board is working.

    pls assist

    Hi everyone its all solved, the stacking pins from mouser were too short and making an interment connection.

    buy the pre soldered version.

    Community Moderator
    Community Moderator

    Hi Mitesh,

    Good news.

    Hi ZoneNetworks,

    You can refer previous comment connect board to PC via USB cable, open COM port and see the print information.