Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BMP390 - data is not displayed on Application board3/BMP390 shuttle board and DD2.

    BMP390 - data is not displayed on Application board3/BMP390 shuttle board and DD2.

    New Poster

    Hi guys,

    I am new to this and need some help. Thank you in advance. 

    I have an application board 3.0 (APP3) with a BMP390 Shuttle Board 3.0 on it.

    I have installed Development Desk 2.0 (UI Ver on Windows 10. 

    My App3 is connected to my PC with Windows 10 through a USB cable.

    I can connect to the APP3 and DD2 displays the sensor main menu. (a graph show pressure and temperature)

    But I don't see any sensor output, just shows the main page of the (pressure & temperature) display.

     I have done the following (step by step): still don't see any data.

    a. updated window driver and was able to recognize the USB interface and connect.

    b. update the bootloader from COINES\v2.7.0\firmware\app3.0\bootloader_update.

    c. updated the DelopmentDesktop_2.0_Firmware_v1.9.bin. from COINES directory.

      Still, I don’t see any action from APP3/BMP390. Just an empty main graph table with no data.


    Note: I did all this because, when I received the APP3/BMP390 the boards were not showing any data and after all

    With these updates, the situation has not changed.


    I am lost and need some help.

    1. Both LEDs on my app3 are lit, orange(good pwr), and RED. is this right?  Should RED be GREEN?

    2. When I try to update flash from DD2 bootloader menu with Blue LED on.

      using DD2 in Boot mode, ‘Setting’ -> ‘Firmware upgrade’ menu. using file

      “DevelopmentDesktop_2.0_frimware_V3.5.fwu2” the system indicate

      “Firmware update in progress...BUT just sits in this position forever, meaning flash

      never completes updating. I have waited 1/2 hour and still no indication of what going on.

      Appreciate any help --- thank you


    5 REPLIES 5

    Community Moderator
    Community Moderator

    Hi jsayed,

    It is not correct when red LED is on. You can refer "C:\COINES\v2.7.0\doc\BST-DHW-AN013.pdf" document and check if you follow the operation step by step.

    Application 3 board Updating bootloader DD firmware and MTP firmware using coines.png


    Hi BSTRobin,
     Thank you for a quick response. Appreciate it, I have a follow-up question as I am still stuck.  When I do what you suggested in your response above and get the green light my PC indicates I am connected. But here  I am in  COINES environment and not in DD2 (GUI).  I wanted to run in DD2 environment and see the pressure/temp. chart  How do I, achieve that?  I followed your steps and got the green LED. but when I run the DD2 it cannot even connect to the board. If I update flash from DD2 after the Blue it just sit there. with Flash updating ...     Thank you

    Hi, someone, anyone PLEASE -- even a hint on my above question (previous remark)..... THANK YOU

    Community Moderator
    Community Moderator

    Hi jsayed,

    COINES environment didn't support to display GUI, you could see it from application note under "C:\COINES\v2.7.0\doc".