Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    BNO055 always reads zero on all sensors and fusions

    BNO055 always reads zero on all sensors and fusions


    Hello, I'm running BNO055 via I2C, basically using examples from the driver, I can talk to the IC, and get those versions:

    chip id A0, softwared rev 311, accel id FB, mag id 32, gyro id F, bootloader rev 15

    I set it into power mode 0 (BNO055_POWER_MODE_NORMAL) and I tried all operation modes, but when I try reading sensor data or fusion data, I get all 0, my quaternion is 0,0,0,0 and each sensor also returns 0,0,0. Calibration status status first reads 0330 (3 for accel and gyro, 0 for sys and mag) in IMU mode, but then reads 0000 for all sensors.

    I tried two different chips, they give the same results. Looks like sensors themselves don't start by some reason, and I can't figure out why.

    9 REPLIES 9


    Additional information: I'm getting 1 from SYS_STATUS and 5 from SYS_ERR, but there don't seem to be any reason for it. I checked all read/writes, I always write at proper addresses and always on page 0, the driver itself properly handles it.

    Another piece of information: if I set operation mode to 8 (IMU) right before reading quaternion, I can get data. But I need to do it every time, it quickly resets to 0 (Config) otherwise. This. obviously, shouldn't be like this, because it's slow and readings seem to be not very good in this way.

    I monitor my I2C, nothing resets it to, it does it by itself. Almost like something restarts the sensor, but there is nothing that could do it.

    Community Moderator
    Community Moderator

    Hello Eirenliel,

    Both power mode and operation mode should be configured. You could refer it from "".
    Is there any difference between your code and github code?

    Hello Sir, I face similar issue in the bno55. What do you mean by setting 8 to operation mode? Can you explain about that?