Bosch Sensortec Community

    Showing results for 
    Search instead for 
    Did you mean: 

    Cannot get Development Desktop 2.0 to connect to App 3.0 board.

    Cannot get Development Desktop 2.0 to connect to App 3.0 board.


    I have Dev Desktop 2.0 UI Version 3.25. on Windows 10

    Coins 2.7 Beta.

    For a driver I can see USBIO Device VID=152A PID=80C0 in windows dev manager.

    I have updated the bootloader with \coines\firmware\app3.0\bootloader_update\usb_ble_dfu_bootloader.pkg. using the .bat file

    I have then updated \COINES\firmware\app3.0\DevelopmentDesktop_2.0_Firmware_v1.9.bin  also using the .bat file.

    At this point the script (update_dd_fw) will end and the the led will go from blue (started with t2 depressed), to red.

    If I run DD2 from the windows desktop, I consistenly get "no response from the board"

    Clearly the basic USB connectivity is working because the board reliably refreshes in device manager and all of the DFU operations work just fine.

    Variations I have tried all yielding the same error on dd2:
    -  the driver above is loaded from:\Program Files\Bosch Sensortec\Development Desktop 2.0\USB Driver.  If I remove this and load the driver at coines\driver\app_board_usb_driver.exe  the device driver is no longer listed as USBIO device, instead its "BST Application Board 2.0" but still under the BST Board node in device manager.

    - I have loaded and perused the memory on the board using MTP at \COINES\v2.7.0\firmware\app3.0\mtp_fw_update with no issues I can see the html files as shipped from Bosch.

    - I have tried a few USB cables.  Same result.  I don't think the hardware is an issue, gun to head, to me it looks like a software issue between the desktop app and the dd2 firmware on the board, as all of the other usb software works.

    Stopped out here.. any help appreciated.

    4 REPLIES 4

    Community Moderator
    Community Moderator

    Hi fcovely,

    Ensure you are using the official Win10 system.
    Which shuttle board did you connect to the app3.0 board?

    l'm definitely on a legit Win 10 system.  I have tried teh BHI360 as well as the BMM350.  Neither work. 

    Having exhaustively tried all combos of firmware for DD2 and coines, I uninstalled everything and checked the registry to make sure there were no lingering drivers, etc.  I reinstalled DD2 and its driver and failed.  Then I installed COINES but this time took a good look at the README file.  I tried the COINES USB driver on DD2, still not working.  However I noticed reference to firmware called coines_bridge.  Which creates a COM port and uses serial rather than straight USB.  I installed the coines_bridge firmware (I think its a beta in COINES 2.7.0).  When I rebooted the board sure enough a new com port got setup and when I ran DD2 it connected!  Bad news is this version of DD2 does not support the BMM350, so back to COINES.  

    Community Moderator
    Community Moderator

    Hi fcovely,

    Good news.
    BHI360 and BMM350 will be supported in DD2.0 in the future.